openSUSE recently disabled the VA-API codecs’ support in their Mesa package. This is was precautionary decision, based on advice from the SUSE legal team. It is actually easy to use the Packman Mesa package instead, which has the codecs enabled still. Just run this:

opi codecs

This will replace your openSUSE repo packages for Mesa with the packages in Packman.